Таблица данных

В таблице данных отображаются ключевые фразы текущей выбранной (активной) группы или мультигруппы.

Таблица состоит из строк и столбцов. Каждая строка соответствует одной фразе, а в колонках отображаются значения той или иной статистики.

Выделение и отметка фраз

Большинство активных функций в программе выполняют операцию либо для выделенных, либо для отмеченных фраз. Выделение удобней использовать для мелких операций, а отметку — для сложных или комплексных процессов.

Выделение фраз выполнятся путем протяжки курсора с зажатой левой кнопкой мыши в области ячеек или зоны нумерации строк. Поддерживается использование выделения с Ctrl и Shift.

В отличие от обычного выделения статус отметки строк сохранятся в проекте и не меняется даже после перезапуска программы.

Например, вы можете продвигаться по таблице вниз, отмечать запросы, не рискуя при этом случайно сбросить выделение. Выделение запросов может использоваться как вспомогательный функционал (можно массово изменить статус отметки для выделенных фраз).

 

Настройка колонок

Вы можете настроить внешний вид таблицы, скрыв пустые или ненужные колонки.

Кнопка вызова менеджера колонок находится в верхнем левом углу таблицы. Скрыть отдельную колонку можно также через контекстное меню ее заголовка.

Инструмент «Авто видимость» на вкладке «Вид» автоматически скрывает все пустые колонки для отфильтрованного набора фраз.

image

Использование менеджера колонок

Установить автоширину для колонок на основе значений можно кнопкой «Авто ширина» на вкладке «Вид».

Для сброса настроек расположения, ширины и видимости колонок можно воспользоваться кнопкой «Сбросить вид» на вкладке «Вид».

 

Вы также можете самостоятельно определить названия для колонок через контекстное меню заголовка колонки.

 

Колонки можно упорядочивать и закреплять в удобной области экрана.

Для фиксации колонок нажмите кнопку фиксации в заголовке или переместите полосу-фиксатор: все колонки, оказавшиеся по ту сторону полосы-фиксатора, окажутся зафиксированными (в таблице имеется левая и правая полосы фиксации).

Сохранение настроек таблицы

Шаблоном вида таблицы называется файл, в котором хранятся настройки внешнего вида таблицы: порядок, видимость и ширина колонок.

Шаблон может быть шаблоном по умолчанию, применяемым автоматически ко всем проектам, может хранится в файле проекта (загружается при открытии проекта) или в файлах шаблонов в неограниченном количестве.

Для создания нового шаблона нажмите на верхнюю часть кнопки «Шаблон вида» на вкладке «Вид» и выберите место хранения шаблона и название. Для применения существующего шаблона нажмите на нижнюю часть кнопки «Шаблон вида».

 
Автоматический поиск шаблонов выполняется лишь в директории «Мои документы/Файлы Key Collector/Шаблоны вида».

Сортировка и фильтрация данных

Сортировка данных

В таблице данных поддерживается сортировка по одной или нескольким колонкам (двойная сортировка).

Включить или отключить поддержку двойной сортировки можно в «Настройках - Интерфейс - Таблица данных - Управление таблицей».

Массово отсортировать все группы по какой-то колонке можно, зажав клавишу Shift. Если нужно установить условия только для выделенных групп, зажмите клавишу Ctrl.

Сортировка в мультигруппах

При работе с мультигруппами по умолчанию фразы в мультигруппе сортируются по порядку следования групп в панели управления группами.

Если вы хотите, чтобы в мультигруппе фразы сортировались по какой-либо колонке со статистикой дополнительно к порядку следования групп, то перед созданием мультигруппы примените для внутренних реальных групп массовую сортировку: зажмите Ctrl и кликните по заголовку нужной колонки. Затем активируйте режим мультигруппы.

Она будет создана в условием сортировки "Родительская группа" + ранее назначенные общие условия сортировки ее групп-источников (например, родительская группа + частотность).

Фильтрация данных

Для отбора фраз также используется система фильтрации данных. Для установки фильтра нажмите кнопку «Редактировать фильтр» на вкладке «Данные» или нажмите кнопку в заголовке колонки.

В открывшемся окне вы можете определить любые условия с поддержкой вложенности.

Для добавления нового условия или группы условий нажмите .

image

Редактор условий фильтрации

Дублирование условий

Для массового создания нескольких одинаковых условий фильтрации нажмите кнопку клонирования условия (если поддерживается) и в открывшемся диалоговом окне введите список операндов.

Сравнение с колонками

Числовые колонки можно сравнивать не только с вручную введенными значениями, но и с другими колонками. Для этого нажмите кнопку и выберите нужную колонку для сравнения.

image

Сравнение точной фразовой частоты с широкой

Калькуляторы таблицы

Таблица данных поддерживает несколько встроенных видов калькуляторов данных. Они позволяют вычислить сумму, минимальное, среднее или максимальное значения непустых значений в колонке.

Для использования функции включите режим «Вычисления» на вкладке «Данные».

Затем в заголовке колонки нажмите кнопку и выберите нужные виды вычислений.

Не используйте калькуляторы таблиц без необходимости, т.к. это может привести к замедлению работы интерфейса.

Значение одного из калькуляторов можно установить приоритетным для отображения в заголовке групп в панели «Управление группами» (для отображения необходимо включить режим отображения вычислений на контекстной вкладке «Вид»).

Поддерживается функция сортировки групп по значению приоритетного калькулятора Узнать больше

Поддерживается функция поиска групп по значению приоритетного калькулятора Узнать больше

Цветовая маркировка

Таблица данных поддерживает несколько видов цветовой маркировки, а также систему пользовательских маркеров. Цвета и маркеры могут использоваться совместно с использованием колонок комментариев и расширяют возможности программы при работе с данными.

Для создания маркировки воспользуйтесь инструментами в блоке «Цвета и маркеры» на вкладке «Данные».

Раскраска строк и ячеек

Для расстановки визуальных акцентов в данных вы можете пользоваться функцией окраски строк или ячеек в таблице.

Окраска ячеек и строк выполняются через инструмент на панели «Цвета и маркеры». Выделите диапазон строк или ячеек, а затем выберите цвет из палитры. Для сброса форматирования воспользуйтесь кнопкой «Сбросить».

Вы можете сортировать и фильтровать фразы по цвету строки. Сортировка может быть применена через контекстное меню заголовка любой колонки в таблице, а фильтр назначен через редактор условий фильтрации (отображаются только существующие в таблице цвета).

Использование цветовой маркировки может замедлять работу программы на больших проектах (десятки и сотни тысяч запросов). Воспользуйтесь режимом облегченной загрузки данных при работе с такими проектами.

Градиентная раскраска (условная раскраска)

Инструмент условной раскраски позволяет автоматически назначить ячейками или строкам в таблице фон на основе значений в той или иной колонке.

Инструмент «Градиент по значениям» находится в блоке «Цвета и маркеры» на вкладке «Данные».

Выберите колонку-источник, режим окрашивания, задайте параметры раскраски и нажмите кнопку «Применить».

Для очистки созданного градиента воспользуйтесь кнопкой «Сбросить».

image

Окно инструмента создания градиента по колонке

Цветовые маркеры

Другим способом промаркеровать фразы в таблице является использование цветовых маркеров. Вы можете использовать маркеры совместно с раскраской строк и ячеек.

Цветовой маркер — это уникальный тег, характеризующийся цветом и названием. В отличие от цвета строки каждая фраза может иметь несколько маркеров одновременно, и маркеры обладают понятным названием (подсказкой при наведении).

Для применения маркера вызовите контекстное меню таблицы. Новый маркер можно применить к отмеченным или выделенным фразам.

Создание и редактирование маркеров

Для создания маркера нажмите кнопку в правом нижнем углу блока «Цвета и маркеры». В открывшемся окне вы создавать новые маркеры, редактировать их цвета и заголовки.

Маркеры могут быть глобальными (доступны для всех проектов) или локальными (доступны только в том проекте, где они создавались). Локальные маркеры могут быть скопированы как глобальные.

Удаление маркеров

Для комплексного удаления маркеров используйте инструмент очистки маркеров, доступ к которому можно получить через контекстное меню заголовка колонки с маркерами.

Инструмент очищает выбранные маркеры для всех фраз в таблице с учетом фильтрации.

Если же требуется удалить маркеры только для выделенных или отмеченных строк (без применения дополнительных фильтров), то для удаления всех маркеров вызовите контекстное меню таблицы и нажмите кнопку , а для удаления конкретного маркера зажмите клавишу D и кликните по маркеру.

Удержание клавиши U удалит все текущие маркеры для выделенных или отмеченных фраз и назначит выбранный маркер (операция замены маркеров).

Фильтрация по маркерам

Для фильтрации фраз по маркеру просто нажмите на сам маркер левой кнопкой мыши. Также можно вызвать контекстное меню заголовка колонки с маркерами и выбрать пункт «Изменить фильтр».

Конвертация маркеров в цвет строки

Если в программе вам удобней работать с маркерами (быстрая фильтрация, аккуратный вид и пр.), но для выгрузок хочется раскрашивать строки целиком, то можно автоматически сконвертировать последний назначенный для фразы маркер (их может быть несколько) в цвет строки.

Функция доступна в контекстном меню заголовка колонки с маркерами.

Редактирование ячеек

Вы можете изменять значения ячеек в таблице. При этом редактировать можно как сами фразы, так и данные в колонках статистики (если они не заблокированы для редактирования).

Перед редактированием фраз убедитесь, что это разрешено в «Настройках — Интерфейс — Таблица данных — Управление таблицей».

Для редактирования фразы нажмите клавишу F2 или совершите двойной клик мышкой по фразе. Ячейка перейдет в режим редактирования.

В силу ограничения уникальности фраз в пределах одной группы допускается ввод только уникальных фраз (в случае нахождения полного дубликата операция редактирования будет отменена).

Для редактирования ячеек в остальных колонках можно поступить аналогичным образом. Однако в дополнение к этому также становится доступной контекстная вкладка «Таблица данных», где вы можете найти дополнительные инструменты для редактирования значений.

Вы можете изменить значения нескольких ячеек в одно действие. Для этого выделите ячейки и нажмите кнопку «Редактировать». В открывшемся диалоговом окне задайте желаемое значение и нажмите кнопку «OK».

Также данные можно вставить из буфера обмена. Для этого предварительно выделите подлежащие редактированию ячейки, а затем воспользуйтесь сочетанием клавиш Ctrl+V.

Инструменты

Теперь когда вы знакомы с основными элементами интерфейса программы и научились работать с таблицей, можно перейти к рассмотрению отдельных инструментов.

Узнать больше